Mandriva Linux Security Advisory : silc-toolkit (MDVSA-2008:158)

High Nessus Plugin ID 36632


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability was found in the SILC toolkit before version 1.1.5 that allowed a remote attacker to cause a denial of service (crash), or possibly execute arbitrary code via long input data (CVE-2008-1227).

A vulnerability was found in the SILC toolkit before version 1.1.7 that allowed a remote attacker to execute arbitrary code via a crafted PKCS#2 message (CVE-2008-1552).

The updated packages have been patched to correct these issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 36632

File Name: mandriva_MDVSA-2008-158.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2009/04/23

Modified: 2016/11/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64silc-1.1_2, p-cpe:/a:mandriva:linux:lib64silcclient-1.1_2, p-cpe:/a:mandriva:linux:libsilc-1.1_2, p-cpe:/a:mandriva:linux:libsilcclient-1.1_2, p-cpe:/a:mandriva:linux:silc-toolkit, p-cpe:/a:mandriva:linux:silc-toolkit-devel, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2008/07/30

Reference Information

CVE: CVE-2008-1227, CVE-2008-1552

MDVSA: 2008:158

CWE: 119, 189