GitLab 19.2 < 19.2.8 / 19.3 < 19.3.5 / 19.4 < 19.4.2 (CVE-2026-97229)

critical Nessus Plugin ID 366188

Synopsis

The version of GitLab installed on the remote host is affected by a vulnerability.

Description

The version of GitLab installed on the remote host is affected by a vulnerability, as follows:

- GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation. (CVE-2026-97229)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 19.2.8, 19.3.5, 19.4.2 or later.

See Also

https://gitlab.com/gitlab-org/gitlab/-/work_items/630686

https://hackerone.com/reports/4055749

https://hackerone.com/reports/4058589

http://www.nessus.org/u?41375083

http://www.nessus.org/u?cab64376

Plugin Details

Severity: Critical

ID: 366188

File Name: gitlab_cve-2026-97229.nasl

Version: 1.6

Type: Combined

Agent: unix

Family: CGI abuses

Published: 10/15/2026

Updated: 11/5/2026

Configuration: Enable thorough checks (optional)

Supported Sensors: Nessus Agent, Continuous Assessment, Tenable Cloud Security, Tenable Self-Hosted Container Security, Nessus

Risk Information

VPR

Risk Factor: Critical

Score: 9.3

Percentile: 99.83

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-97229

CVSS v3

Risk Factor: Critical

Base Score: 10

Temporal Score: 9.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/13/2026

Vulnerability Publication Date: 10/12/2026

CISA Known Exploited Vulnerability Due Dates: 11/1/2026

Exploitable With

Metasploit (GitLab CI/CD RegExp Integer Overflow Remote Code Execution)

Reference Information

CVE: CVE-2026-97229

IAVA: 2026-A-1121