Mandriva Linux Security Advisory : amarok (MDVSA-2008:172)

Low Nessus Plugin ID 36594


The remote Mandriva Linux host is missing one or more security updates.


A flaw in Amarok prior to 1.4.10 would allow local users to overwrite arbitrary files via a symlink attack on a temporary file that Amarok created with a predictable name (CVE-2008-3699).

The updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Low

ID: 36594

File Name: mandriva_MDVSA-2008-172.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2009/04/23

Modified: 2015/03/30

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 3.3

Temporal Score: 2.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:amarok, p-cpe:/a:mandriva:linux:amarok-engine-void, p-cpe:/a:mandriva:linux:amarok-engine-xine, p-cpe:/a:mandriva:linux:amarok-engine-yauap, p-cpe:/a:mandriva:linux:amarok-scripts, p-cpe:/a:mandriva:linux:lib64amarok-devel, p-cpe:/a:mandriva:linux:lib64amarok-scripts-devel, p-cpe:/a:mandriva:linux:lib64amarok0, p-cpe:/a:mandriva:linux:lib64amarok0-scripts, p-cpe:/a:mandriva:linux:libamarok-devel, p-cpe:/a:mandriva:linux:libamarok-scripts-devel, p-cpe:/a:mandriva:linux:libamarok0, p-cpe:/a:mandriva:linux:libamarok0-scripts, cpe:/o:mandriva:linux:2008.0, cpe:/o:mandriva:linux:2008.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/08/15

Reference Information

CVE: CVE-2008-3699

BID: 30662

MDVSA: 2008:172

CWE: 59