Ubuntu 7.10 / 8.04 LTS : moodle vulnerability (USN-658-1)

Medium Nessus Plugin ID 36491


The remote Ubuntu host is missing a security-related patch.


Lukasz Pilorz discovered that the HTML filtering used in Moodle was not strict enough. A remote attacker could send malicious requests to Moodle and execute arbitrary code as the web server user.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected moodle package.

Plugin Details

Severity: Medium

ID: 36491

File Name: ubuntu_USN-658-1.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2009/04/23

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:moodle, cpe:/o:canonical:ubuntu_linux:7.10, cpe:/o:canonical:ubuntu_linux:8.04:-:lts

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/10/23

Exploitable With

CANVAS (D2ExploitPack)

Elliot (Moodle <= 1.8.4 RCE)

Reference Information

CVE: CVE-2008-1502

OSVDB: 43677

USN: 658-1

CWE: 79