Mandriva Linux Security Advisory : blender (MDVSA-2008:204)

Medium Nessus Plugin ID 36425


The remote Mandriva Linux host is missing a security update.


Stefan Cornelius of Secunia Research reported a boundary error when Blender processed RGBE images which could be used to execute arbitrary code with the privileges of the user running Blender if a specially crafted .hdr or .blend file were opened(CVE-2008-1102).

As well, multiple vulnerabilities involving insecure usage of temporary files had also been reported (CVE-2008-1103).

The updated packages have been patched to prevent these issues.


Update the affected blender package.

Plugin Details

Severity: Medium

ID: 36425

File Name: mandriva_MDVSA-2008-204.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2009/04/23

Modified: 2016/11/28

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:blender, cpe:/o:mandriva:linux:2008.0, cpe:/o:mandriva:linux:2008.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2008/09/24

Reference Information

CVE: CVE-2008-1102, CVE-2008-1103

MDVSA: 2008:204

CWE: 59, 119