Mandriva Linux Security Advisory : audacity (MDVSA-2009:055)

High Nessus Plugin ID 36403


The remote Mandriva Linux host is missing a security update.


A vulnerability has been identified and corrected in audacity :

Stack-based buffer overflow in the String_parse::get_nonspace_quoted function in lib-src/allegro/strparse.cpp in Audacity 1.2.6 and other versions before 1.3.6 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a .gro file containing a long string (CVE-2009-0490).

The updated packages have been patched to prevent this.


Update the affected audacity package.

Plugin Details

Severity: High

ID: 36403

File Name: mandriva_MDVSA-2009-055.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/04/23

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:audacity, cpe:/o:mandriva:linux:2008.0, cpe:/o:mandriva:linux:2008.1, cpe:/o:mandriva:linux:2009.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2009/02/25

Reference Information

CVE: CVE-2009-0490

MDVSA: 2009:055

CWE: 119