Mandriva Linux Security Advisory : clamav (MDVSA-2008:003)

Critical Nessus Plugin ID 36347


The remote Mandriva Linux host is missing one or more security updates.


An integer overflow vulnerability was reported by iDefense with clamav when parsing Portable Executable (PE) files packed in he MEW format.
This could be exploited to cause a heap-based buffer overflow (CVE-2007-6335).

Toeroek Edwin reported an off-by-one error when decompressing MS-ZIP compressed CAB files (CVE-2007-6336).

As well, an unspecified vulnerability related to the bzip2 decompression algorithm was also discovered (CVE-2007-6337).

Other bugs have also been corrected in 0.92 which is being provided with this update. Because this new version has increased the major of the libclamav library, updated dependent packages are also being provided.


Update the affected packages.

Plugin Details

Severity: Critical

ID: 36347

File Name: mandriva_MDVSA-2008-003.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2009/04/23

Modified: 2013/06/03

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:clamav, p-cpe:/a:mandriva:linux:clamav-db, p-cpe:/a:mandriva:linux:clamav-milter, p-cpe:/a:mandriva:linux:clamd, p-cpe:/a:mandriva:linux:clamdmon, p-cpe:/a:mandriva:linux:klamav, p-cpe:/a:mandriva:linux:lib64clamav-devel, p-cpe:/a:mandriva:linux:lib64clamav3, p-cpe:/a:mandriva:linux:libclamav-devel, p-cpe:/a:mandriva:linux:libclamav3, cpe:/o:mandriva:linux:2007, cpe:/o:mandriva:linux:2007.1, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2008/01/08

Reference Information

CVE: CVE-2007-6335, CVE-2007-6336, CVE-2007-6337

MDVSA: 2008:003

CWE: 119, 189