Mandriva Linux Security Advisory : amarok (MDVSA-2009:030-1)

High Nessus Plugin ID 36306


The remote Mandriva Linux host is missing one or more security updates.


Data length values in metadata Audible Audio media file (.aa) can lead to an integer overflow enabling remote attackers use it to trigger an heap overflow and enabling the possibility to execute arbitrary code (CVE-2009-0135).

Failure on checking heap allocation on Audible Audio media files (.aa) allows remote attackers either to cause denial of service or execute arbitrary code via a crafted media file (CVE-2009-0136).

This update provide the fix for these security issues.

Update :

Packages for 2008.0 are provided for Corporate Desktop 2008.0 customers


Update the affected packages.

Plugin Details

Severity: High

ID: 36306

File Name: mandriva_MDVSA-2009-030.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2009/04/23

Modified: 2016/11/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:amarok, p-cpe:/a:mandriva:linux:amarok-engine-xine, p-cpe:/a:mandriva:linux:amarok-scripts, p-cpe:/a:mandriva:linux:lib64amarok-devel, p-cpe:/a:mandriva:linux:lib64amarok-scripts-devel, p-cpe:/a:mandriva:linux:lib64amarok0, p-cpe:/a:mandriva:linux:lib64amarok0-scripts, p-cpe:/a:mandriva:linux:libamarok-devel, p-cpe:/a:mandriva:linux:libamarok-scripts-devel, p-cpe:/a:mandriva:linux:libamarok0, p-cpe:/a:mandriva:linux:libamarok0-scripts, cpe:/o:mandriva:linux:2008.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/12/08

Reference Information

CVE: CVE-2009-0135, CVE-2009-0136

BID: 33210

MDVSA: 2009:030-1

CWE: 119, 189