Mandriva Linux Security Advisory : dbus (MDVSA-2008:213)

Low Nessus Plugin ID 36288


The remote Mandriva Linux host is missing one or more security updates.


The D-Bus library did not correctly validate certain corrupted signatures which could cause a crash of applications linked against the D-Bus library if a local user were to send a specially crafted D-Bus request (CVE-2008-3834).

The updated packages have been patched to prevent this issue.


Update the affected packages.

Plugin Details

Severity: Low

ID: 36288

File Name: mandriva_MDVSA-2008-213.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/04/23

Modified: 2013/06/01

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:dbus, p-cpe:/a:mandriva:linux:dbus-x11, p-cpe:/a:mandriva:linux:lib64dbus-1-devel, p-cpe:/a:mandriva:linux:lib64dbus-1_3, p-cpe:/a:mandriva:linux:lib64dbus-1_3-devel, p-cpe:/a:mandriva:linux:libdbus-1-devel, p-cpe:/a:mandriva:linux:libdbus-1_3, p-cpe:/a:mandriva:linux:libdbus-1_3-devel, cpe:/o:mandriva:linux:2008.0, cpe:/o:mandriva:linux:2008.1, cpe:/o:mandriva:linux:2009.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2008/10/15

Reference Information

CVE: CVE-2008-3834

MDVSA: 2008:213

CWE: 20