GLSA-200904-14 : F-PROT Antivirus: Multiple Denial of Service vulnerabilities

Medium Nessus Plugin ID 36158


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200904-14 (F-PROT Antivirus: Multiple Denial of Service vulnerabilities)

The following vulnerabilities were found:
Multiple errors when processing UPX, ASPack or Microsoft Office files (CVE-2008-3243).
Infinite Sergio Alvarez of n.runs AG reported an invalid memory access when processing a CHM file with a large nb_dir value (CVE-2008-3244).
Jonathan Brossard from iViZ Techno Solutions reported that F-PROT Antivirus does not correctly process ELF binaries with corrupted headers (CVE-2008-5747).
Impact :

A remote attacker could entice a user or automated system to scan a specially crafted file, leading to a crash or infinite loop.
Workaround :

There is no known workaround at this time.


All F-PROT Antivirus users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-antivirus/f-prot-6.0.2'

See Also

Plugin Details

Severity: Medium

ID: 36158

File Name: gentoo_GLSA-200904-14.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2009/04/15

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:f-prot, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2009/04/14

Reference Information

CVE: CVE-2008-3243, CVE-2008-3244, CVE-2008-5747

OSVDB: 51134

GLSA: 200904-14

CWE: 20, 399