MS09-009: Vulnerabilities in Microsoft Office Excel Could Cause Remote Code Execution (968557)

High Nessus Plugin ID 36147


It is possible to execute arbitrary code on the remote Windows host using Microsoft Excel.


The remote host contains a version of Microsoft Excel / Excel Viewer / 2007 Microsoft Office system and the Microsoft Office Compatibility Pack that is affected by two memory corruption vulnerabilities. If an attacker can trick a user on the affected host into opening a specially crafted Excel file, either of these issues could be leveraged to run arbitrary code on the host subject to the user's privileges.


Microsoft has released a set of patches for Excel 2000, 2002, 2003, and 2007, Excel Viewer and Excel Viewer 2003 as well as the 2007 Microsoft Office system and the Microsoft Office Compatibility Pack.

See Also

Plugin Details

Severity: High

ID: 36147

File Name: smb_nt_ms09-009.nasl

Version: $Revision: 1.31 $

Type: local

Agent: windows

Published: 2009/04/15

Modified: 2017/08/09

Dependencies: 11336, 27524, 57033

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:office

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/04/14

Vulnerability Publication Date: 2009/02/24

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-0100, CVE-2009-0238

BID: 33870, 34413

OSVDB: 52695, 53665

MSFT: MS09-009

MSKB: 959964, 959988, 959993, 959995, 959997, 960000, 960003

CWE: 94, 399