Debian DSA-1770-1 : imp4 - Insufficient input sanitising

Medium Nessus Plugin ID 36146

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been found in imp4, a webmail component for the horde framework. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2008-4182 It was discovered that imp4 suffers from a cross-site scripting (XSS) attack via the user field in an IMAP session, which allows attackers to inject arbitrary HTML code.

- CVE-2009-0930 It was discovered that imp4 is prone to several cross-site scripting (XSS) attacks via several vectors in the mail code allowing attackers to inject arbitrary HTML code.

Solution

Upgrade the imp4 packages.

For the oldstable distribution (etch), these problems have been fixed in version 4.1.3-4etch1.

For the stable distribution (lenny), these problems have been fixed in version 4.2-4, which was already included in the lenny release.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=500114

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=500553

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=513266

https://security-tracker.debian.org/tracker/CVE-2008-4182

https://security-tracker.debian.org/tracker/CVE-2009-0930

https://www.debian.org/security/2009/dsa-1770

Plugin Details

Severity: Medium

ID: 36146

File Name: debian_DSA-1770.nasl

Version: 1.13

Type: local

Agent: unix

Published: 2009/04/14

Updated: 2018/11/28

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:imp4, cpe:/o:debian:debian_linux:4.0, cpe:/o:debian:debian_linux:5.0

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/04/13

Reference Information

CVE: CVE-2008-4182, CVE-2009-0930

BID: 31168, 33492

DSA: 1770

CWE: 79