ClamAV < 0.95.1 Multiple Vulnerabilities

Medium Nessus Plugin ID 36131

Synopsis

The remote antivirus service is affected by multiple vulnerabilities.

Description

According to its version, the clamd antivirus daemon on the remote host is earlier than 0.95.1. Such versions are affected by multiple vulnerabilities :

- ClamAV might crash while scanning certain malicious files packed with UPack. (Bug #1552)

- ClamAV might crash while using 'cli_url_canon'. (Bug #1553)

Solution

Upgrade to ClamAV 0.95.1 or later.

See Also

https://bugzilla.clamav.net/show_bug.cgi?id=1552

https://bugzilla.clamav.net/show_bug.cgi?id=1553

Plugin Details

Severity: Medium

ID: 36131

File Name: clamav_0_95_1.nasl

Version: 1.16

Type: remote

Family: Misc.

Published: 2009/04/10

Updated: 2018/07/06

Dependencies: 11153

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:clamav:clamav

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2009-1371, CVE-2009-1372

BID: 34446

CWE: 20, 119