GLSA-200904-01 : Openfire: Multiple vulnerabilities

High Nessus Plugin ID 36078


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200904-01 (Openfire: Multiple vulnerabilities)

Two vulnerabilities have been reported by Federico Muttis, from CORE IMPACT's Exploit Writing Team:
Multiple missing or incomplete input validations in several .jsps (CVE-2009-0496).
Incorrect input validation of the 'log' parameter in log.jsp (CVE-2009-0497).
Multiple vulnerabilities have been reported by Andreas Kurtz:
Erroneous built-in exceptions to input validation in login.jsp (CVE-2008-6508).
Unsanitized user input to the 'type' parameter in sipark-log-summary.jsp used in SQL statement. (CVE-2008-6509) A Cross-Site-Scripting vulnerability due to unsanitized input to the 'url' parameter. (CVE-2008-6510, CVE-2008-6511) Impact :

A remote attacker could execute arbitrary code on clients' systems by uploading a specially crafted plugin, bypassing authentication.
Additionally, an attacker could read arbitrary files on the server or execute arbitrary SQL statements. Depending on the server's configuration the attacker might also execute code on the server via an SQL injection.
Workaround :

There is no known workaround at this time.


All Openfire users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-im/openfire-3.6.3'

See Also

Plugin Details

Severity: High

ID: 36078

File Name: gentoo_GLSA-200904-01.nasl

Version: $Revision: 1.17 $

Type: local

Published: 2009/04/03

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openfire, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/04/02

Exploitable With

Core Impact

Metasploit (Openfire Admin Console Authentication Bypass)

Reference Information

CVE: CVE-2008-6508, CVE-2008-6509, CVE-2008-6510, CVE-2008-6511, CVE-2009-0496, CVE-2009-0497

BID: 32189, 32935, 32937, 32938, 32939, 32940, 32943, 32944, 32945

OSVDB: 49663, 51419, 51420, 51421, 51422, 51423, 51424, 51425, 51426, 51912, 52902, 52903

GLSA: 200904-01

CWE: 20, 22, 79, 89