Firefox < 3.0.8 Multiple Vulnerabilities

High Nessus Plugin ID 36045


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox is earlier than 3.0.8. Such versions are potentially affected by the following security issues :

- An XSL transformation vulnerability can be leveraged with a specially crafted stylesheet to crash the browser or to execute arbitrary code. (MFSA 2009-12)

- An error in the XUL tree method '_moveToEdgeShift()' can be leveraged to trigger garbage collection routines on objects that are still in use, leading to a browser crash and possibly execution of arbitrary code. (MFSA 2009-13)


Upgrade to Firefox 3.0.8 or later.

See Also

Plugin Details

Severity: High

ID: 36045

File Name: mozilla_firefox_308.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Family: Windows

Published: 2009/03/30

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/03/27

Reference Information

CVE: CVE-2009-1044, CVE-2009-1169

BID: 34181, 34235

OSVDB: 52896, 53079

CWE: 399