GLSA-200903-35 : Muttprint: Insecure temporary file usage

Medium Nessus Plugin ID 36001


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200903-35 (Muttprint: Insecure temporary file usage)

Dmitry E. Oboukhov reported an insecure usage of the temporary file '/tmp/muttprint.log' in the muttprint script.
Impact :

A local attacker could perform symlink attacks to overwrite arbitrary files with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All Muttprint users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-misc/muttprint-0.72d-r1'

See Also

Plugin Details

Severity: Medium

ID: 36001

File Name: gentoo_GLSA-200903-35.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/03/24

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:muttprint, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2009/03/23

Reference Information

CVE: CVE-2008-5368

OSVDB: 50665

GLSA: 200903-35

CWE: 59