Adobe Reader < 9.1 / 8.1.4 / 7.1.1 Multiple Vulnerabilities
High Nessus Plugin ID 35821
SynopsisThe PDF file viewer on the remote Windows host is affected by multiple vulnerabilities.
DescriptionThe version of Adobe Reader installed on the remote host is earlier than 9.1 / 8.1.4 / 7.1.1. Such versions are reportedly affected by multiple vulnerabilities :
- An integer buffer overflow can be triggered when processing a malformed JBIG2 image stream with the '/JBIG2Decode' filter. (CVE-2009-0658)
- Additional vulnerabilities involving handling of JBIG2 image streams could lead to remote code execution.
(CVE-2009-0193, CVE-2009-0928, CVE-2009-1061, CVE-2009-1062)
If an attacker can trick a user into opening a specially crafted PDF file, these flaws can exploited to execute arbitrary code subject to the user's privileges.
SolutionUpgrade to Adobe Reader 9.1 / 8.1.4 / 7.1.1 or later.