Adobe Reader < 9.1 / 8.1.4 / 7.1.1 Multiple Vulnerabilities

High Nessus Plugin ID 35821


The PDF file viewer on the remote Windows host is affected by multiple vulnerabilities.


The version of Adobe Reader installed on the remote host is earlier than 9.1 / 8.1.4 / 7.1.1. Such versions are reportedly affected by multiple vulnerabilities :

- An integer buffer overflow can be triggered when processing a malformed JBIG2 image stream with the '/JBIG2Decode' filter. (CVE-2009-0658)

- A vulnerability in the 'getIcon()' JavaScript method of a Collab object could allow for remote code execution. (CVE-2009-0927)

- Additional vulnerabilities involving handling of JBIG2 image streams could lead to remote code execution.
(CVE-2009-0193, CVE-2009-0928, CVE-2009-1061, CVE-2009-1062)

If an attacker can trick a user into opening a specially crafted PDF file, these flaws can exploited to execute arbitrary code subject to the user's privileges.


Upgrade to Adobe Reader 9.1 / 8.1.4 / 7.1.1 or later.

See Also

Plugin Details

Severity: High

ID: 35821

File Name: adobe_reader_91.nasl

Version: $Revision: 1.29 $

Type: local

Agent: windows

Family: Windows

Published: 2009/03/11

Modified: 2016/11/11

Dependencies: 20836

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Acroread/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/03/10

Exploitable With


Core Impact

Metasploit (Adobe Collab.getIcon() Buffer Overflow)

Reference Information

CVE: CVE-2009-0193, CVE-2009-0658, CVE-2009-0927, CVE-2009-0928, CVE-2009-1061, CVE-2009-1062

BID: 33751, 34169, 34229

OSVDB: 52073, 53644, 53645, 53646, 53647, 53648

TRA: TRA-2009-01

EDB-ID: 8099

Secunia: 33901

CWE: 20, 119