GLSA-200903-19 : Xerces-C++: Denial of Service

High Nessus Plugin ID 35817

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200903-19 (Xerces-C++: Denial of Service)

Frank Rast reported that the XML parser in Xerces-C++ does not correctly handle an XML schema definition with a large maxOccurs value, which triggers excessive memory consumption during the validation of an XML file.
Impact :

A remote attacker could entice a user or automated system to validate an XML file using a specially crafted XML schema file, leading to a Denial of Service (stack consumption and crash).
Workaround :

There is no known workaround at this time.

Solution

All Xerces-C++ users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/xerces-c-3.0.0-r1'

See Also

https://security.gentoo.org/glsa/200903-19

Plugin Details

Severity: High

ID: 35817

File Name: gentoo_GLSA-200903-19.nasl

Version: 1.12

Type: local

Published: 2009/03/10

Updated: 2018/08/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:xerces-c, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2009/03/09

Reference Information

CVE: CVE-2008-4482

GLSA: 200903-19

CWE: 20