GLSA-200903-14 : BIND: Incorrect signature verification

Medium Nessus Plugin ID 35812


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200903-14 (BIND: Incorrect signature verification)

BIND does not properly check the return value from the OpenSSL functions to verify DSA (CVE-2009-0025) and RSA (CVE-2009-0265) certificates.
Impact :

A remote attacker could bypass validation of the certificate chain to spoof DNSSEC-authenticated records.
Workaround :

There is no known workaround at this time.


All BIND users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-dns/bind-9.4.3_p1'

See Also

Plugin Details

Severity: Medium

ID: 35812

File Name: gentoo_GLSA-200903-14.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2009/03/10

Modified: 2016/05/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:ND/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:bind, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/03/09

Reference Information

CVE: CVE-2009-0025, CVE-2009-0265

BID: 33150, 33151

OSVDB: 51368, 53115

GLSA: 200903-14

CWE: 287