Opera < 9.64 Multiple Vulnerabilities

High Nessus Plugin ID 35761


The remote host contains a web browser that is affected by multiple issues.


The version of Opera installed on the remote host is earlier than 9.64 and thus reportedly affected by multiple issues :

- A memory-corruption vulnerability when processing specially crafted JPEG files could allow an attacker to execute arbitrary code with the privileges of the affected application. (926)
- It may be possible for certain plugins to execute arbitrary code in the context of a different domain. An attacker could exploit this to steal authentication credentials as well as carry out other attacks.


Upgrade to Opera 9.64 or later.

See Also



Plugin Details

Severity: High

ID: 35761

File Name: opera_964.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2009/03/03

Modified: 2011/04/13

Dependencies: 21746

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2009-0914, CVE-2009-0915, CVE-2009-0916

BID: 33961

OSVDB: 52645, 52646, 52647

CWE: 399