GLSA-200902-05 : KTorrent: Multiple vulnerabilitites

Medium Nessus Plugin ID 35731


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200902-05 (KTorrent: Multiple vulnerabilitites)

The web interface plugin does not restrict access to the torrent upload functionality (CVE-2008-5905) and does not sanitize request parameters properly (CVE-2008-5906) .
Impact :

A remote attacker could send specially crafted parameters to the web interface that would allow for arbitrary torrent uploads and remote code execution with the privileges of the KTorrent process.
Workaround :

Disabling the web interface plugin will prevent exploitation of both issues. Click 'Plugins' in the configuration menu and uncheck the checkbox left of 'WebInterface', then apply the changes.


All KTorrent users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-p2p/ktorrent-2.2.8'

See Also

Plugin Details

Severity: Medium

ID: 35731

File Name: gentoo_GLSA-200902-05.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2009/02/24

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ktorrent, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/02/23

Reference Information

CVE: CVE-2008-5905, CVE-2008-5906

BID: 31927

OSVDB: 49356, 49357

GLSA: 200902-05

CWE: 20, 264