Safari < 3.2.2 Multiple Vulnerabilities

High Nessus Plugin ID 35687


The remote host contains a web browser with multiple vulnerabilities.


The version of Safari installed on the remote Windows host is earlier than 3.2.2. Such versions reportedly have multiple security vulnerabilities :

- Input validation issues in their handling of 'feed:' URLs, which could be abused to execute arbitrary JavaScript code in the local security zone.

- A cached certificate is not required before displaying a lock icon for a HTTPS website. This allows a man- in-the-middle attacker to present the user with spoofed web pages over HTTPS that appear to be from a legitimate source.

- The browser processes a 3xx HTTP CONNECT before a successful SSL handshake, which could allow a man-in- the-middle attacker to execute arbitrary script code in the context of a HTTPS site.


Upgrade to Safari 3.2.2 or later.

See Also

Plugin Details

Severity: High

ID: 35687

File Name: safari_3_2_2.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Family: Windows

Published: 2009/02/13

Modified: 2016/12/14

Dependencies: 31788

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: SMB/Safari/FileVersion

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2009-0137, CVE-2009-2062, CVE-2009-2072

BID: 33234, 35411, 35412

OSVDB: 53991, 56486, 56491

CWE: 20, 287