Google Chrome < 1.0.154.46 Multiple Vulnerabilities

Medium Nessus Plugin ID 35558

Synopsis

The remote host contains a web browser that is affected by multiple vulnerabilities.

Description

The version of Google Chrome installed on the remote host is earlier than 1.0.154.46. Such versions are reportedly affected by several issues :

- Cross-site scripting vulnerabilities in the Adobe Reader Plugin itself could be leveraged using a PDF document to run scripts on arbitrary sites via Google Chrome.
(CVE-2007-0048 and CVE-2007-0045)

- A cross-domain security-bypass vulnerability that could allow an attacker to bypass the same-origin policy and gain access to potentially sensitive information.
(CVE-2009-0276)

- A remote attacker may be able to gain access to the 'Set-Cookie' and 'Set-Cookie2' response headers via XMLHttpRequest calls. (CVE-2009-0411)

Solution

Upgrade to Google Chrome version 1.0.154.46 or later.

See Also

http://www.nessus.org/u?4e94a6f2

Plugin Details

Severity: Medium

ID: 35558

File Name: google_chrome_1_0_154_46.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2009/01/31

Modified: 2013/11/13

Dependencies: 34196

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/01/28

Vulnerability Publication Date: 2006/12/27

Reference Information

CVE: CVE-2007-0045, CVE-2007-0048, CVE-2009-0276, CVE-2009-0411

BID: 21858, 33529, 33773

OSVDB: 31046, 31596, 52641, 54156

CWE: 264