GLSA-200901-14 : Scilab: Insecure temporary file usage

Medium Nessus Plugin ID 35443


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200901-14 (Scilab: Insecure temporary file usage)

Dmitry E. Oboukhov reported an insecure temporary file usage within the scilink, scidoc and scidem scripts.
Impact :

A local attacker could perform symlink attacks to overwrite arbitrary files with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All Scilab users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sci-mathematics/scilab-4.1.2-r1'

See Also

Plugin Details

Severity: Medium

ID: 35443

File Name: gentoo_GLSA-200901-14.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/01/22

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:scilab, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2009/01/21

Reference Information

CVE: CVE-2008-4983

OSVDB: 49644, 49645, 49646

GLSA: 200901-14

CWE: 59