Fedora 8 : xterm-238-1.fc8 (2009-0154)

High Nessus Plugin ID 35391


The remote Fedora host is missing a security update.


This update fixes the following security issue: CRLF injection vulnerability in xterm allows user-assisted attackers to execute arbitrary commands via LF (aka \n) characters surrounding a command name within a Device Control Request Status String (DECRQSS) escape sequence in a text file, a related issue to CVE-2003-0063 and CVE-2003-0071.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected xterm package.

See Also



Plugin Details

Severity: High

ID: 35391

File Name: fedora_2009-0154.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2009/01/16

Modified: 2015/10/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:xterm, cpe:/o:fedoraproject:fedora:8

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2009/01/07

Reference Information

CVE: CVE-2008-2383

FEDORA: 2009-0154

CWE: 94