GLSA-200901-04 : D-Bus: Denial of Service

Low Nessus Plugin ID 35348

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200901-04 (D-Bus: Denial of Service)

schelte reported that the dbus_signature_validate() function can trigger a failed assertion when processing a message containing a malformed signature.
Impact :

A local user could send a specially crafted message to the D-Bus daemon, leading to a Denial of Service.
Workaround :

There is no known workaround at this time.

Solution

All D-Bus users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-apps/dbus-1.2.3-r1'

See Also

https://security.gentoo.org/glsa/200901-04

Plugin Details

Severity: Low

ID: 35348

File Name: gentoo_GLSA-200901-04.nasl

Version: 1.15

Type: local

Published: 2009/01/12

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.1

Temporal Score: 1.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:dbus, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/01/11

Reference Information

CVE: CVE-2008-3834

BID: 31602

GLSA: 200901-04

CWE: 20