GLSA-200901-01 : NDISwrapper: Arbitrary remote code execution

High Nessus Plugin ID 35345


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200901-01 (NDISwrapper: Arbitrary remote code execution)

Anders Kaseorg reported multiple buffer overflows related to long ESSIDs.
Impact :

A physically proximate attacker could send packets over a wireless network that might lead to the execution of arbitrary code with root privileges.
Workaround :

There is no known workaround at this time.


All NDISwrapper users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-wireless/ndiswrapper-1.53-r1'

See Also

Plugin Details

Severity: High

ID: 35345

File Name: gentoo_GLSA-200901-01.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2009/01/12

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 8.3

Vector: CVSS2#AV:A/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ndiswrapper, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2009/01/11

Reference Information

CVE: CVE-2008-4395

OSVDB: 49726

GLSA: 200901-01

CWE: 119