Samba 3.2.0 - 3.2.6 Unauthorized Access

Medium Nessus Plugin ID 35298


The remote Samba server may be affected by an unauthorized access vulnerability.


According to its banner, the version of the Samba server on the remote host is between 3.2.0 and 3.2.6 inclusive. Such versions reportedly allow an authenticated, remote user to gain access to the root filesystem, subject to his or her privileges, by making a request for a share called '' (empty string) from a version of smbclient prior to 3.0.28. Successful exploitation of this issue requires 'registry shares' to be enabled, which is not enabled by default.

Note that Nessus has not actually tried to exploit this issue or to determine if 'registry shares' is enabled or if the fix has been applied.


Upgrade to Samba version 3.2.7 or later or apply the appropriate patch referenced in the project's advisory.

See Also

Plugin Details

Severity: Medium

ID: 35298

File Name: samba_3_2_7.nasl

Version: $Revision: 1.13 $

Type: remote

Family: Misc.

Published: 2009/01/06

Modified: 2016/05/13

Dependencies: 10785

Risk Information

Risk Factor: Medium


Base Score: 6

Temporal Score: 5.2

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/samba, SMB/NativeLanManager, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2009-0022

BID: 33118

OSVDB: 51152

Secunia: 33379

CWE: 20