GLSA-200812-15 : POV-Ray: User-assisted execution of arbitrary code

High Nessus Plugin ID 35107


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200812-15 (POV-Ray: User-assisted execution of arbitrary code)

POV-Ray uses a statically linked copy of libpng to view and output PNG files. The version shipped with POV-Ray is vulnerable to CVE-2008-3964, CVE-2008-1382, CVE-2006-3334, CVE-2006-0481, CVE-2004-0768. A bug in POV-Ray's build system caused it to load the old version when your installed copy of libpng was >=media-libs/libpng-1.2.10.
Impact :

An attacker could entice a user to load a specially crafted PNG file as a texture, resulting in the execution of arbitrary code with the permissions of the user running the application.
Workaround :

There is no known workaround at this time.


All POV-Ray users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-gfx/povray-3.6.1-r4'

See Also

Plugin Details

Severity: High

ID: 35107

File Name: gentoo_GLSA-200812-15.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2008/12/15

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:povray, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/12/14

Vulnerability Publication Date: 2004/08/04

Reference Information

CVE: CVE-2004-0768, CVE-2006-0481, CVE-2006-3334, CVE-2008-1382, CVE-2008-3964

BID: 18698, 28770

OSVDB: 10711, 22850, 28160, 44364, 48298

GLSA: 200812-15

CWE: 189, 399