VLC Media Player 0.9.x < 0.9.8a RealMedia Processing Remote Integer Overflow

High Nessus Plugin ID 35068


The remote Windows host contains an application that is affected by an integer overflow vulnerability.


The version of VLC media player 0.9 installed on the remote host is earlier than 0.9.8a. Such versions contain a heap-based integer buffer overflow in the Real demuxer plugin (libreal_plugin.*'). If an attacker can trick a user into opening a specially crafted RealMedia (.rm) file, arbitrary code could be executed within the context of the affected application.


Upgrade to VLC Media Player version 0.9.8a or later.

See Also




Plugin Details

Severity: High

ID: 35068

File Name: vlc_0_9_8a.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2008/12/09

Modified: 2016/11/03

Dependencies: 31852

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2008-5276

BID: 32545

OSVDB: 50333

CWE: 189