Debian DSA-1680-1 : clamav - buffer overflow, stack consumption

High Nessus Plugin ID 35033

Synopsis

The remote Debian host is missing a security-related update.

Description

Moritz Jodeit discovered that ClamAV, an anti-virus solution, suffers from an off-by-one-error in its VBA project file processing, leading to a heap-based buffer overflow and potentially arbitrary code execution (CVE-2008-5050 ).

Ilja van Sprundel discovered that ClamAV contains a denial of service condition in its JPEG file processing because it does not limit the recursion depth when processing JPEG thumbnails (CVE-2008-5314 ).

Solution

Upgrade the clamav packages.

For the stable distribution (etch), these problems have been fixed in version 0.90.1dfsg-4etch16.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505134

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507624

https://security-tracker.debian.org/tracker/CVE-2008-5050

https://security-tracker.debian.org/tracker/CVE-2008-5314

https://www.debian.org/security/2008/dsa-1680

Plugin Details

Severity: High

ID: 35033

File Name: debian_DSA-1680.nasl

Version: 1.13

Type: local

Agent: unix

Published: 2008/12/04

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:clamav, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/12/04

Reference Information

CVE: CVE-2008-5050, CVE-2008-5314

BID: 32207

DSA: 1680

CWE: 119, 399