Opera < 9.62 Multiple Vulnerabilities

High Nessus Plugin ID 34680


The remote host contains a web browser that is affected by several issues.


The version of Opera installed on the remote host is earlier than 9.62 and thus reportedly affected by several issues :

- Opera fails to sanitize certain parameters passed to the 'History Search' (906).

- The browser's same-origin policy may be violated because scripts running in the 'Links Panel' always run in the outermost frame of the page (907).

Successful exploitation would result in the attacker being able to execute arbitrary script code in the unsuspecting user's browser and may also lead to cookie-based credential theft, browser setting modifications, and other attacks.

These attacks require that the attacker be able to trick a user into browsing to a malicious URI with the affected application.


Upgrade to Opera 9.62 or later.

See Also





Plugin Details

Severity: High

ID: 34680

File Name: opera_962.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2008/10/31

Modified: 2016/12/07

Dependencies: 21746

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version

Exploit Available: true

Exploit Ease: Exploits are available

Exploitable With

Metasploit (Opera historysearch XSS)

Reference Information

CVE: CVE-2008-4794, CVE-2008-4795

BID: 31991

OSVDB: 49472, 49473

CWE: 20, 79