Opera < 9.61 Multiple Vulnerabilities

Medium Nessus Plugin ID 34459


The remote host contains a web browser that is affected by several issues.


The version of Opera installed on the remote host is earlier than 9.61 and thus reportedly affected by several issues :

- It may be possible to reveal a user's browsing history by exploiting certain constructs in Opera's History Search results (903).

- Opera's Fast Forward feature is affected by a cross-site scripting vulnerability (904).

- While previewing certain news feeds, it may be possible for certain scripts to subscribe an user to arbitrary feeds, and also view contents of user subscribed feeds (905).


Upgrade to Opera 9.61 or later.

See Also





Plugin Details

Severity: Medium

ID: 34459

File Name: opera_961.nasl

Version: $Revision: 1.11 $

Type: local

Agent: windows

Family: Windows

Published: 2008/10/21

Modified: 2016/12/07

Dependencies: 21746

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version

Exploit Available: true

Exploit Ease: Exploits are available

Exploitable With

CANVAS (D2ExploitPack)

Core Impact

Metasploit (Opera historysearch XSS)

Reference Information

CVE: CVE-2008-4696, CVE-2008-4697, CVE-2008-4698, CVE-2008-4725

BID: 31842, 31869

OSVDB: 49738, 49739, 49740, 49741

Secunia: 32299

CWE: 79, 264