Debian DSA-1652-1 : ruby1.9 - several vulnerabilities

High Nessus Plugin ID 34388

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.6

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in the interpreter for the Ruby language, which may lead to denial of service and other security problems. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2008-3655 Keita Yamaguchi discovered that several safe level restrictions are insufficiently enforced.

- CVE-2008-3656 Christian Neukirchen discovered that the WebRick module uses inefficient algorithms for HTTP header splitting, resulting in denial of service through resource exhaustion.

- CVE-2008-3657 It was discovered that the dl module doesn't perform taintness checks.

- CVE-2008-3790 Luka Treiber and Mitja Kolsek discovered that recursively nested XML entities can lead to denial of service through resource exhaustion in rexml.

- CVE-2008-3905 Tanaka Akira discovered that the resolv module uses sequential transaction IDs and a fixed source port for DNS queries, which makes it more vulnerable to DNS spoofing attacks.

Solution

Upgrade the ruby1.9 packages.

For the stable distribution (etch), these problems have been fixed in version 1.9.0+20060609-1etch3. Packages for arm will be provided later.

See Also

https://security-tracker.debian.org/tracker/CVE-2008-3655

https://security-tracker.debian.org/tracker/CVE-2008-3656

https://security-tracker.debian.org/tracker/CVE-2008-3657

https://security-tracker.debian.org/tracker/CVE-2008-3790

https://security-tracker.debian.org/tracker/CVE-2008-3905

https://www.debian.org/security/2008/dsa-1652

Plugin Details

Severity: High

ID: 34388

File Name: debian_DSA-1652.nasl

Version: 1.17

Type: local

Agent: unix

Published: 2008/10/13

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 6.6

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ruby1.9, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/10/12

Reference Information

CVE: CVE-2008-3655, CVE-2008-3656, CVE-2008-3657, CVE-2008-3790, CVE-2008-3905

BID: 30644, 30802, 31699

DSA: 1652

CWE: 20, 264, 287, 399