GLSA-200809-10 : Mantis: Multiple vulnerabilities

High Nessus Plugin ID 34250


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200809-10 (Mantis: Multiple vulnerabilities)

Antonio Parata and Francesco Ongaro reported a Cross-Site Request Forgery vulnerability in manage_user_create.php (CVE-2008-2276), a Cross-Site Scripting vulnerability in return_dynamic_filters.php (CVE-2008-3331), and an insufficient input validation in adm_config_set.php (CVE-2008-3332). A directory traversal vulnerability in core/lang_api.php (CVE-2008-3333) has also been reported.
Impact :

A remote attacker could exploit these vulnerabilities to execute arbitrary HTML and script code, create arbitrary users with administrative privileges, execute arbitrary PHP commands, and include arbitrary files.
Workaround :

There is no known workaround at this time.


All Mantis users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/mantisbt-1.1.2'

See Also

Plugin Details

Severity: High

ID: 34250

File Name: gentoo_GLSA-200809-10.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2008/09/22

Modified: 2016/11/11

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mantisbt, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/09/21

Exploitable With

Elliot (Mantis <= 1.1.1 LFI)

Reference Information

CVE: CVE-2008-2276, CVE-2008-3331, CVE-2008-3332, CVE-2008-3333

OSVDB: 45214, 47175, 47176, 47854

GLSA: 200809-10

CWE: 22, 79, 94, 352