Wireshark / Ethereal < 1.0.3 Multiple Vulnerabilities

Low Nessus Plugin ID 34113


The remote host has an application that is affected by multiple vulnerabilities.


The installed version of Wireshark or Ethereal is affected by multiple issues :

- The NCP dissector is affected by multiple buffer overflow flaws, and in certain cases may enter a infinite loop (Bug 2675).

- While uncompressing zlib-compressed packet data, Wireshark could crash (Bug 2649).

- While reading a Tektronix .rf5 file, Wireshark could crash.


Upgrade to Wireshark 1.0.3 or later.

See Also


Plugin Details

Severity: Low

ID: 34113

File Name: wireshark_1_0_3.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2008/09/09

Modified: 2016/05/06

Dependencies: 34112

Risk Information

Risk Factor: Low


Base Score: 2.6

Temporal Score: 2.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

BID: 31009