Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : libxml2 vulnerability (USN-640-1)

Medium Nessus Plugin ID 34094

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

Andreas Solberg discovered that libxml2 did not handle recursive entities safely. If an application linked against libxml2 were made to process a specially crafted XML document, a remote attacker could exhaust the system's CPU resources, leading to a denial of service.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

See Also

https://usn.ubuntu.com/640-1/

Plugin Details

Severity: Medium

ID: 34094

File Name: ubuntu_USN-640-1.nasl

Version: 1.14

Type: local

Agent: unix

Published: 2008/09/05

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:libxml2, p-cpe:/a:canonical:ubuntu_linux:libxml2-dbg, p-cpe:/a:canonical:ubuntu_linux:libxml2-dev, p-cpe:/a:canonical:ubuntu_linux:libxml2-doc, p-cpe:/a:canonical:ubuntu_linux:libxml2-utils, p-cpe:/a:canonical:ubuntu_linux:python-libxml2, p-cpe:/a:canonical:ubuntu_linux:python-libxml2-dbg, p-cpe:/a:canonical:ubuntu_linux:python2.4-libxml2, cpe:/o:canonical:ubuntu_linux:6.06:-:lts, cpe:/o:canonical:ubuntu_linux:7.04, cpe:/o:canonical:ubuntu_linux:7.10, cpe:/o:canonical:ubuntu_linux:8.04:-:lts

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/09/03

Reference Information

CVE: CVE-2008-3281

BID: 30783

USN: 640-1

CWE: 399