hMailServer < 4.4.2 build 279 IMAP Command Handling Remote DoS

Medium Nessus Plugin ID 33902


The remote host has an application that is affected by a denial of service vulnerability.


The remote host is running hMailServer, a mail server for Windows.

By sending large amounts of data along with certain IMAP commands such as 'CREATE' or 'RENAME', an authenticated user may be able to crash the remote mail server.


Upgrade to hMailServer 4.4.2-B279 or later.

See Also

Plugin Details

Severity: Medium

ID: 33902

File Name: hmailserver_remote_dos.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2008/08/16

Modified: 2016/05/11

Dependencies: 13855, 17975

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2008-3676

BID: 30663

OSVDB: 47459

CWE: 20