GLSA-200808-08 : stunnel: Security bypass

Medium Nessus Plugin ID 33854


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200808-08 (stunnel: Security bypass)

An unspecified bug in the OCSP search functionality of stunnel has been discovered.
Impact :

A remote attacker can use a revoked certificate that would be successfully authenticated by stunnel. This issue only concerns the users who have enabled the OCSP validation in stunnel.
Workaround :

There is no known workaround at this time.


All stunnel users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/stunnel-4.24'

See Also

Plugin Details

Severity: Medium

ID: 33854

File Name: gentoo_GLSA-200808-08.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2008/08/10

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:stunnel, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2008/08/08

Reference Information

CVE: CVE-2008-2420

OSVDB: 45357

GLSA: 200808-08

CWE: 264