GLSA-200808-05 : ISC DHCP: Denial of Service

Critical Nessus Plugin ID 33835


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200808-05 (ISC DHCP: Denial of Service)

A buffer overflow error was found in ISC DHCP server, that can only be exploited under unusual server configurations where the DHCP server is configured to provide clients with a large set of DHCP options.
Impact :

A remote attacker could exploit this vulnerability to cause a Denial of Service.
Workaround :

There is no known workaround at this time.


All ISC DHCP users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/dhcp-3.1.1'

See Also

Plugin Details

Severity: Critical

ID: 33835

File Name: gentoo_GLSA-200808-05.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2008/08/07

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:dhcp, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2008/08/06

Reference Information

CVE: CVE-2007-0062

OSVDB: 40094

GLSA: 200808-05

CWE: 119, 189