Winamp < 5.541 NowPlaying Feature Metadata XSS

Medium Nessus Plugin ID 33820


The remote Windows host contains a multimedia application that is affected by a cross-site script vulnerability.


The remote host is running Winamp, a media player for Windows.

The version of Winamp installed on the remote host is earlier than 5.541. Such versions reportedly contain a cross-site scripting vulnerability involving the software's 'NowPlaying' feature because the embedded browser fails to sanitize metadata in media files of JavaScript before displaying it to the user.


Upgrade to Winamp version 5.541 or later.

See Also

Plugin Details

Severity: Medium

ID: 33820

File Name: winamp_5541.nasl

Version: $Revision: 1.13 $

Type: local

Agent: windows

Family: Windows

Published: 2008/08/05

Modified: 2016/05/06

Dependencies: 15817

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:nullsoft:winamp

Required KB Items: SMB/Winamp/Version

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2008-3567

BID: 30539

OSVDB: 47347

Secunia: 31371

CWE: 79