Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : libxslt vulnerabilities (USN-633-1)

High Nessus Plugin ID 33808


The remote Ubuntu host is missing one or more security-related patches.


It was discovered that long transformation matches in libxslt could overflow. If an attacker were able to make an application linked against libxslt process malicious XSL style sheet input, they could execute arbitrary code with user privileges or cause the application to crash, leading to a denial of serivce. (CVE-2008-1767)

Chris Evans discovered that the RC4 processing code in libxslt did not correctly handle corrupted key information. If a remote attacker were able to make an application linked against libxslt process malicious XML input, they could crash the application, leading to a denial of service. (CVE-2008-2935).

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 33808

File Name: ubuntu_USN-633-1.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2008/08/04

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:libxslt1-dbg, p-cpe:/a:canonical:ubuntu_linux:libxslt1-dev, p-cpe:/a:canonical:ubuntu_linux:libxslt1.1, p-cpe:/a:canonical:ubuntu_linux:python-libxslt1, p-cpe:/a:canonical:ubuntu_linux:python-libxslt1-dbg, p-cpe:/a:canonical:ubuntu_linux:python2.4-libxslt1, p-cpe:/a:canonical:ubuntu_linux:xsltproc, cpe:/o:canonical:ubuntu_linux:6.06:-:lts, cpe:/o:canonical:ubuntu_linux:7.04, cpe:/o:canonical:ubuntu_linux:7.10, cpe:/o:canonical:ubuntu_linux:8.04:-:lts

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/08/01

Reference Information

CVE: CVE-2008-1767, CVE-2008-2935

BID: 29312

OSVDB: 47544

USN: 633-1

CWE: 119