Ubuntu 7.10 / 8.04 LTS : ffmpeg vulnerability (USN-630-1)

High Nessus Plugin ID 33759


The remote Ubuntu host is missing one or more security-related patches.


It was discovered that ffmpeg did not correctly handle STR file demuxing. If a user were tricked into processing a malicious STR file, a remote attacker could execute arbitrary code with user privileges via applications linked against ffmpeg.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 33759

File Name: ubuntu_USN-630-1.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2008/07/29

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:ffmpeg, p-cpe:/a:canonical:ubuntu_linux:libavcodec-dev, p-cpe:/a:canonical:ubuntu_linux:libavcodec1d, p-cpe:/a:canonical:ubuntu_linux:libavformat-dev, p-cpe:/a:canonical:ubuntu_linux:libavformat1d, p-cpe:/a:canonical:ubuntu_linux:libavutil-dev, p-cpe:/a:canonical:ubuntu_linux:libavutil1d, p-cpe:/a:canonical:ubuntu_linux:libpostproc-dev, p-cpe:/a:canonical:ubuntu_linux:libpostproc1d, p-cpe:/a:canonical:ubuntu_linux:libswscale-dev, p-cpe:/a:canonical:ubuntu_linux:libswscale1d, cpe:/o:canonical:ubuntu_linux:7.10, cpe:/o:canonical:ubuntu_linux:8.04:-:lts

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2008/07/28

Reference Information

CVE: CVE-2008-3162

USN: 630-1

CWE: 119