CUPS < 1.3.8 PNG File Handling Multiple Overflows

High Nessus Plugin ID 33577


The remote printer service (CUPS) is affected by a buffer overflow vulnerability.


According to its banner, the version of CUPS installed on the remote host is affected by an integer overflow. Using a specially crafted PNG file with overly long width and height fields, a remote attacker can leverage this issue to crash the affected service and may allow execution of arbitrary code.


Upgrade to CUPS version 1.3.8 or later.

See Also

Plugin Details

Severity: High

ID: 33577

File Name: cups_1_3_8.nasl

Version: $Revision: 1.18 $

Type: remote

Family: Misc.

Published: 2008/07/25

Modified: 2016/05/04

Dependencies: 10107, 29727

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:cups

Required KB Items: www/cups, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2008-1722

BID: 28781

OSVDB: 44398

CERT: 218395

Secunia: 29809

CWE: 20