Firefox 3.x < 3.0.1 Multiple Vulnerabilities

High Nessus Plugin ID 33522


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox is affected by various security issues :

- By creating a very large number of references to a common CSS object, an attacker can overflow the CSS reference counter, causing a crash when the browser attempts to free the CSS object while still in use and allowing for arbitrary code execution (MFSA 2008-34).

- If Firefox is not already running, passing it a command-line URI with pipe ('|') symbols will open multiple tabs, which could be used to launch 'chrome:i' URIs from the command-line or to pass URIs to Firefox that would normally be handled by a vector application (MFSA 2008-35).


Upgrade to Firefox 3.0.1 or later.

See Also

Plugin Details

Severity: High

ID: 33522

File Name: mozilla_firefox_301.nasl

Version: $Revision: 1.15 $

Type: local

Agent: windows

Family: Windows

Published: 2008/07/17

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:U/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/07/15

Reference Information

CVE: CVE-2008-2785, CVE-2008-2933, CVE-2008-3198

BID: 29802, 30242, 30244

OSVDB: 46421, 47465, 48782

CWE: 20, 94, 189