Debian DSA-1610-1 : gaim - integer overflow

Medium Nessus Plugin ID 33508

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that gaim, an multi-protocol instant messaging client, was vulnerable to several integer overflows in its MSN protocol handlers. These could allow a remote attacker to execute arbitrary code.

Solution

Upgrade the gaim package.

For the stable distribution (etch), this problem has been fixed in version 1:2.0.0+beta5-10etch1.

See Also

https://www.debian.org/security/2008/dsa-1610

Plugin Details

Severity: Medium

ID: 33508

File Name: debian_DSA-1610.nasl

Version: 1.14

Type: local

Agent: unix

Published: 2008/07/16

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gaim, cpe:/o:debian:debian_linux:4.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2008/07/15

Reference Information

CVE: CVE-2008-2927

DSA: 1610

CWE: 189