GLSA-200807-05 : OpenOffice.org: User-assisted execution of arbitrary code

High Nessus Plugin ID 33472

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200807-05 (OpenOffice.org: User-assisted execution of arbitrary code)

Sean Larsson (iDefense Labs) reported an integer overflow in the function rtl_allocateMemory() in the file sal/rtl/source/alloc_global.c.
Impact :

A remote attacker could entice a user to open a specially crafted document, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.

Solution

All OpenOffice.org users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/openoffice-2.4.1' All OpenOffice.org binary users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/openoffice-bin-2.4.1'

See Also

https://security.gentoo.org/glsa/200807-05

Plugin Details

Severity: High

ID: 33472

File Name: gentoo_GLSA-200807-05.nasl

Version: 1.13

Type: local

Published: 2008/07/10

Updated: 2018/08/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openoffice, p-cpe:/a:gentoo:linux:openoffice-bin, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2008/07/09

Reference Information

CVE: CVE-2008-2152

GLSA: 200807-05

CWE: 189