Mac OS X : Apple Safari < 3.1.2

High Nessus Plugin ID 33286


The remote host contains a web browser that is affected by a buffer overflow vulnerability.


The version of Apple Safari installed on the remote host reportedly has a memory corruption issue in WebKit's handling of JavaScript arrays.


Upgrade to Apple Safari 3.1.2 or later.

See Also

Plugin Details

Severity: High

ID: 33286

File Name: macosx_Safari3_1_2.nasl

Version: $Revision: 1.14 $

Type: local

Agent: macosx

Published: 2008/07/01

Modified: 2016/05/17

Dependencies: 31604

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: Host/local_checks_enabled, Host/uname, Host/MacOSX/Version, MacOSX/Safari/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/06/30

Reference Information

CVE: CVE-2008-2307

BID: 29836

OSVDB: 46502

Secunia: 30801

CWE: 399