VLC Media Player < 0.8.6h Multiple Vulnerabilities

high Nessus Plugin ID 33278
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote Windows host contains a media player that is affected by several vulnerabilities.


The version of VLC Media Player installed on the remote host reportedly includes versions of GnuTLS, libgcrypt, and libxml2 that are affected by various denial of service and buffer overflow vulnerabilities.


Upgrade to VLC Media Player version 0.8.6h or later.

See Also


Plugin Details

Severity: High

ID: 33278

File Name: vlc_0_8_6h.nasl

Version: 1.11

Type: local

Agent: windows

Family: Windows

Published: 6/30/2008

Updated: 8/6/2018

Dependencies: vlc_installed.nasl

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2008-1948, CVE-2008-1949, CVE-2008-1950, CVE-2007-6284

BID: 27248, 29292

CWE: 189, 287, 399