GLSA-200806-07 : X.Org X server: Multiple vulnerabilities

Critical Nessus Plugin ID 33243

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200806-07 (X.Org X server: Multiple vulnerabilities)

Regenrecht reported multiple vulnerabilities in various X server extensions via iDefense:
The SProcSecurityGenerateAuthorization() and SProcRecordCreateContext() functions of the RECORD and Security extensions are lacking proper parameter validation (CVE-2008-1377).
An integer overflow is possible in the function ShmPutImage() of the MIT-SHM extension (CVE-2008-1379).
The RENDER extension contains several possible integer overflows in the AllocateGlyph() function (CVE-2008-2360) which could possibly lead to a heap-based buffer overflow. Further possible integer overflows have been found in the ProcRenderCreateCursor() function (CVE-2008-2361) as well as in the SProcRenderCreateLinearGradient(), SProcRenderCreateRadialGradient() and SProcRenderCreateConicalGradient() functions (CVE-2008-2362).
Impact :

Exploitation of these vulnerabilities could possibly lead to the remote execution of arbitrary code with root privileges, if the server is running as root, which is the default. It is also possible to crash the server by making use of these vulnerabilities.
Workaround :

It is possible to avoid these vulnerabilities by disabling the affected server extensions. Therefore edit the configuration file (/etc/X11/xorg.conf) to contain the following in the appropriate places:
Section 'Extensions' Option 'MIT-SHM' 'disable' Option 'RENDER' 'disable' Option 'SECURITY' 'disable' EndSection Section 'Module' Disable 'record' EndSection

Solution

All X.org X Server users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-base/xorg-server-1.3.0.0-r6'

See Also

https://security.gentoo.org/glsa/200806-07

Plugin Details

Severity: Critical

ID: 33243

File Name: gentoo_GLSA-200806-07.nasl

Version: 1.14

Type: local

Published: 2008/06/24

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:xorg-server, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/06/19

Reference Information

CVE: CVE-2008-1377, CVE-2008-1379, CVE-2008-2360, CVE-2008-2361, CVE-2008-2362

GLSA: 200806-07

CWE: 189